Unable to launch or terminate instances on Lambda public cloud
Monitoring·Partial outage

Severity Level: High A fix has been implemented and we’re monitoring the results. All regions are back online. To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button. Thank you for your patience and understanding during this time.

Thu, Sep 11, 2025, 02:09 PM
(2 days ago)
·
Affected components
Updates

Monitoring

Severity Level: High A fix has been implemented and we’re monitoring the results. All regions are back online. To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button. Thank you for your patience and understanding during this time.

Thu, Sep 11, 2025, 02:09 PM

Monitoring

Severity Level: High A fix has been implemented and we’re monitoring the results. All regions are back online. To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button. Thank you for your patience and understanding during this time.

Wed, Sep 10, 2025, 09:28 PM(16 hours earlier)

Monitoring

Severity Level: High We identified the root cause of an issue in our public cloud environment affecting the ability to launch or terminate instances. The issue has been resolved and systems are under active monitoring. Impact:

  • Existing, active instances remain unaffected and accessible.

If you are unsure whether your service is impacted, please open a support ticket. To receive automatic notifications of status changes, click “Subscribe to updates.” Thank you for your patience and understanding.

Wed, Sep 10, 2025, 09:11 PM(16 minutes earlier)

Investigating

Severity Level: High We’re currently investigating an issue with our public cloud environment. Users may experience the inability to launch or terminate instances during this time. Our engineers are actively working to identify the root cause of the issue. This DOES NOT impact existing, active instances and users will still be able to access these. UPDATES:

  • US-WEST-3 region is not included in this incident and users can still launch/terminate instances as expected.

  • US-SOUTH-3 region is back online and services have been restored.

  • US-MIDWEST-2 region is back online and services have been restored.

  • US-EAST-2 region is back online and services have been restored.

  • US-SOUTH-1 region is back online and services have been restored.


In the event you’re unsure as to whether your service is impacted by this incident, please open a support ticket. We’ll get back to you as soon as possible.


To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button. Thank you for your patience and understanding during this time.

Wed, Sep 10, 2025, 08:52 PM(19 minutes earlier)

Investigating

Severity Level: High We’re currently investigating an issue with our public cloud environment. Users may experience the inability to launch or terminate instances during this time. Our engineers are actively working to identify the root cause of the issue. This DOES NOT impact existing, active instances and users will still be able to access these. UPDATES:

  • US-WEST-3 region is not included in this incident and users can still launch/terminate instances as expected.

  • US-SOUTH-3 region is back online and services have been restored.

  • US-MIDWEST-2 region is back online and services have been restored.

  • US-EAST-2 region is back online and services have been restored.

In the event you’re unsure as to whether your service is impacted by this incident, please open a support ticket. We’ll get back to you as soon as possible. • https://support.lambdalabs.com/hc/en-us/requests/new To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button. Thank you for your patience and understanding during this time.

Wed, Sep 10, 2025, 07:15 PM(1 hour earlier)

Investigating

Severity Level: High We’re currently investigating an issue with our public cloud environment. Users may experience the inability to launch or terminate instances during this time. Our engineers are actively working to identify the root cause of the issue. This DOES NOT impact existing, active instances and users will still be able to access these. UPDATES:

  • US-WEST-3 region is not included in this incident and users can still launch/terminate instances as expected.

  • US-SOUTH-3 region is back online and services have been restored.

  • US-MIDWEST-2 region is back online and services have been restored.

In the event you’re unsure as to whether your service is impacted by this incident, please open a support ticket. We’ll get back to you as soon as possible. • https://support.lambdalabs.com/hc/en-us/requests/new To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button. Thank you for your patience and understanding during this time.

Wed, Sep 10, 2025, 06:23 PM(52 minutes earlier)

Investigating

Severity Level: High We’re currently investigating an issue with our public cloud environment. Users may experience the inability to launch or terminate instances during this time. Our engineers are actively working to identify the root cause of the issue. This DOES NOT impact existing, active instances and users will still be able to access these. UPDATE: US-WEST-3 region is not included in this incident and users can still launch/terminate instances as expected. US-SOUTH-3 region is back online and services have been restored. In the event you’re unsure as to whether your service is impacted by this incident, please open a support ticket. We’ll get back to you as soon as possible. • https://support.lambdalabs.com/hc/en-us/requests/new To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button. Thank you for your patience and understanding during this time.

Wed, Sep 10, 2025, 05:45 PM(37 minutes earlier)

Investigating

Severity Level: [Low/Medium/High/Critical] We’re currently investigating an issue with our public cloud environment. Users may experience the inability to launch or terminate instances during this time. Our engineers are actively working to identify the root cause of the issue. This DOES NOT impact existing, active instances and users will still be able to access these. UPDATE: US-WEST-3 region is not included in this incident and users can still launch/terminate instances as expected. In the event you’re unsure as to whether your service is impacted by this incident, please open a support ticket. We’ll get back to you as soon as possible.

To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button. Thank you for your patience and understanding during this time.

Wed, Sep 10, 2025, 04:17 PM(1 hour earlier)

Investigating

Severity Level: [High] We’re currently investigating an issue with our public cloud environment. Users may experience the inability to launch or terminate instances during this time. Our engineers are actively working to identify the root cause of the issue. This DOES NOT impact existing, active instances and users will still be able to access these. In the event you’re unsure as to whether your service is impacted by this incident, please open a support ticket. We’ll get back to you as soon as possible.

To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button. Thank you for your patience and understanding during this time.

Wed, Sep 10, 2025, 04:05 PM(12 minutes earlier)