Lambda GPU Cloud

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Power Maintenance Causing Loss of Power Redundancy in us-west-3
Resolved·Degraded performance

Severity Level: [Low]

The incident has been resolved.

-----------------------------------------------------------------------------

Again, in the event you’re unsure as to whether your service is still impacted by this, please open a support ticket and we’ll get back to you as soon as possible.

  • https://support.lambdalabs.com/hc/en-us/requests/new

To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button.

Fri, Mar 20, 2026, 03:23 PM
(6 months ago)
·
Affected components
Mar 19, 2026, 08:12 PM
Mar 20, 2026, 03:23 PM
Power
Updates

Resolved

Severity Level: [Low]

The incident has been resolved.

-----------------------------------------------------------------------------

Again, in the event you’re unsure as to whether your service is still impacted by this, please open a support ticket and we’ll get back to you as soon as possible.

  • https://support.lambdalabs.com/hc/en-us/requests/new

To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button.

Fri, Mar 20, 2026, 03:23 PM

Identified

Severity Level: [Low]

A scheduled power maintenance is being conducted tonight, 03/19/26, in the us-west-3 region. This will cause a loss of power redundancy, but is not expected to cause any customer impact for our On-Demand Cloud customers.

Thank you for your patience and understanding during this time.

-----------------------------------------------------------------------------

In the event you’re unsure as to whether your service is impacted by this incident, please open a support ticket. We’ll get back to you as soon as possible.

  • https://support.lambdalabs.com/hc/en-us/requests/new

To be automatically notified when the status of this incident changes, please click on the “Subscribe to updates” button.

Thu, Mar 19, 2026, 08:12 PM(19 hours earlier)